Joomla исправила критическую уязвимость SQL-инъекции в релизе 3.7.1

Выпущенное в среду обновление движка Joomla исправляет критическую уязвимость SQL-инъекций, которая может быть легко использована удаленным злоумышленником для получения конфиденциальных данных и взлома веб-сайтов.

Эта брешь была обнаружена экспертом Sucuri и получила идентификатор CVE-2017-8917. Уязвимость затрагивает версию Joomla 3.7.0, а в релизе 3.7.1 уже устранена.

По словам исследователя, уязвимость влияет только на Joomla 3.7, поскольку она связана с новым компонентом, представленным в этой версии. Речь идет о компоненте com_fields.

Поскольку com_fields является публичным, любой может использовать эту уязвимость, не имея привилегированной учетной записи на целевом сайте. Злоумышленник может эксплуатировать брешь для вставки вложенных SQL-запросов с помощью специально созданного URL-адреса.

«Учитывая природу атак SQL-инъекция, существует множество способов, которыми злоумышленник может нанести вред. Например, это может привести к утечке хэшей паролей и краже сеанса зарегистрированного пользователя. Последнее приведет к полной компрометации сайта, если получена сессия администратора» — предупреждает эксперт в своем блоге.

Пользователям Joomla рекомендуется как можно скорее обновить версию, используемую на их сайтах. Так как технические детали уязвимости уже были опубликованы в открытом доступе, не стоит удивляться росту числа атак, эксплуатирующих эту брешь.